 All Classes
RapidaExample
RapidaExample.PAYM_SUBJ_TYPE
RapidaExample.Request
RapidaExample.Request.HTTP_METHOD


Constant Field Values

Contents
Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Deprecated List

PREV NEXT FRAMES NO FRAMES

Deprecated API

Contents
Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


API Help

PREV NEXT FRAMES NO FRAMES

How This API Document Is Organized

This API (Application Programming Interface) document has pages corresponding to the items in the navigation bar, described as follows.

Package

Each package has a page that contains a list of its classes and interfaces, with a summary for each. This page can contain four categories:

  • Interfaces (italic)
  • Classes
  • Enums
  • Exceptions
  • Errors
  • Annotation Types

Class/Interface

Each class, interface, nested class and nested interface has its own separate page. Each of these pages has three sections consisting of a class/interface description, summary tables, and detailed member descriptions:

  • Class inheritance diagram
  • Direct Subclasses
  • All Known Subinterfaces
  • All Known Implementing Classes
  • Class/interface declaration
  • Class/interface description

  • Nested Class Summary
  • Field Summary
  • Constructor Summary
  • Method Summary

  • Field Detail
  • Constructor Detail
  • Method Detail
Each summary entry contains the first sentence from the detailed description for that item. The summary entries are alphabetical, while the detailed descriptions are in the order they appear in the source code. This preserves the logical groupings established by the programmer.

Annotation Type

Each annotation type has its own separate page with the following sections:

  • Annotation Type declaration
  • Annotation Type description
  • Required Element Summary
  • Optional Element Summary
  • Element Detail

Enum

Each enum has its own separate page with the following sections:

  • Enum declaration
  • Enum description
  • Enum Constant Summary
  • Enum Constant Detail

Use

Each documented package, class and interface has its own Use page. This page describes what packages, classes, methods, constructors and fields use any part of the given class or package. Given a class or interface A, its Use page includes subclasses of A, fields declared as A, methods that return A, and methods and constructors with parameters of type A. You can access this page by first going to the package, class or interface, then clicking on the "Use" link in the navigation bar.

Tree (Class Hierarchy)

There is a Class Hierarchy page for all packages, plus a hierarchy for each package. Each hierarchy page contains a list of classes and a list of interfaces. The classes are organized by inheritance structure starting with java.lang.Object. The interfaces do not inherit from java.lang.Object.
  • When viewing the Overview page, clicking on "Tree" displays the hierarchy for all packages.
  • When viewing a particular package, class or interface page, clicking "Tree" displays the hierarchy for only that package.

Deprecated API

The Deprecated API page lists all of the API that have been deprecated. A deprecated API is not recommended for use, generally due to improvements, and a replacement API is usually given. Deprecated APIs may be removed in future implementations.

Index

The Index contains an alphabetic list of all classes, interfaces, constructors, methods, and fields.

Prev/Next

These links take you to the next or previous class, interface, package, or related page.

Frames/No Frames

These links show and hide the HTML frames. All pages are available with or without frames.

Serialized Form

Each serializable or externalizable class has a description of its serialization fields and methods. This information is of interest to re-implementors, not to developers using the API. While there is no link in the navigation bar, you can get to this information by going to any serialized class and clicking "Serialized Form" in the "See also" section of the class description.

Constant Field Values

The Constant Field Values page lists the static final fields and their values.

This help file applies to API documentation generated using the standard doclet.

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Generated Documentation (Untitled)

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


PREV NEXT FRAMES NO FRAMES

Hierarchy For All Packages

Package Hierarchies:
ru.rapida

Class Hierarchy

  • java.lang.Object
    • ru.rapida.RapidaExample
    • ru.rapida.RapidaExample.Request

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
      • ru.rapida.RapidaExample.Request.HTTP_METHOD
Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


C-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

C

cancel(String) - Method in class ru.rapida.RapidaExample
Запрос на отмену платежа
check(String, int, List<String>, int, int) - Method in class ru.rapida.RapidaExample
Запрос проверки правильности параметров платежа
Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V


G-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

G

getBalance(String) - Method in class ru.rapida.RapidaExample
Запрос на получение остатка средтв участника системы
getFactory(File, String) - Static method in class ru.rapida.RapidaExample
Возвращает объект SSLSocketFactory из контейнера pkcs12
getFee() - Method in class ru.rapida.RapidaExample
Запрос справочника получателей
getId() - Method in enum ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
Возвращает идентификатор
getPaymSubj(RapidaExample.PAYM_SUBJ_TYPE, String) - Method in class ru.rapida.RapidaExample
Запрос на получение кода ТСП
getStatus(String) - Method in class ru.rapida.RapidaExample
Запрос статуса платежа
Package Class Use Tree Deprecated Index Help
C G M P R S T V


M-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

M

main(String[]) - Static method in class ru.rapida.RapidaExample
Пример использования класса (все статические методы используются для примера работы)
makePaymExtId() - Static method in class ru.rapida.RapidaExample
Создает paymExtId (рекомендуется реализовать более надежный алгоритм)
Package Class Use Tree Deprecated Index Help
C G M P R S T V


P-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

P

payment(String, int, List<String>, int, int) - Method in class ru.rapida.RapidaExample
Запрос проведения платежа
Package Class Use Tree Deprecated Index Help
C G M P R S T V


R-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

R

RapidaExample - Class in ru.rapida
Пример работы с платежной системой "Рапида" (все статические методы используются для примера работы, остальное реализует протокол)
на данный момент корректная работа гарантируется с JRE <= 1.6.0_18
RapidaExample(String, String, String, SSLSocketFactory, Proxy) - Constructor for class ru.rapida.RapidaExample
Конструктор сласса
RapidaExample.PAYM_SUBJ_TYPE - Enum in ru.rapida
Перечисление групп кодов назначения.
RapidaExample.Request - Class in ru.rapida
Класс отправки запроса на сервер
RapidaExample.Request(String, RapidaExample.Request.HTTP_METHOD, Map<String, String>, SSLSocketFactory, Proxy) - Constructor for class ru.rapida.RapidaExample.Request
Конструктор объекта
RapidaExample.Request.HTTP_METHOD - Enum in ru.rapida
Перечисление методов HTTP запроса
respAlalyzer(byte[]) - Static method in class ru.rapida.RapidaExample
Анализирует ответ сервера.
responseProcessor(byte[]) - Method in class ru.rapida.RapidaExample.Request
Обработчик даннных полученных от сервера (метод send возвращает результат обработки данных от сервера методом responseProcessor)
ru.rapida - package ru.rapida
Package Class Use Tree Deprecated Index Help
C G M P R S T V


S-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

S

send() - Method in class ru.rapida.RapidaExample.Request
Отправляет запрос и возвращает полученные данные
Package Class Use Tree Deprecated Index Help
C G M P R S T V


T-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

T

toString() - Method in enum ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
Возвращает идентификатор в виде строки
Package Class Use Tree Deprecated Index Help
C G M P R S T V


V-Index

PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V

V

valueOf(String) - Static method in enum ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum ru.rapida.RapidaExample.Request.HTTP_METHOD
Returns the enum constant of this type with the specified name.
values() - Static method in enum ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum ru.rapida.RapidaExample.Request.HTTP_METHOD
Returns an array containing the constants of this enum type, in the order they are declared.
Package Class Use Tree Deprecated Index Help
PREV LETTER NEXT LETTER FRAMES NO FRAMES
C G M P R S T V


 ru.rapida
Classes
RapidaExample
RapidaExample.Request
Enums
RapidaExample.PAYM_SUBJ_TYPE
RapidaExample.Request.HTTP_METHOD


ru.rapida

PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES

Package ru.rapida

Class Summary
RapidaExample | Пример работы с платежной системой "Рапида" (все статические методы используются для примера работы, остальное реализует протокол) на данный момент корректная работа гарантируется с JRE <= 1.6.0_18
RapidaExample.Request | Класс отправки запроса на сервер

Enum Summary
RapidaExample.PAYM_SUBJ_TYPE | Перечисление групп кодов назначения.
RapidaExample.Request.HTTP_METHOD | Перечисление методов HTTP запроса

Package Class Use Tree Deprecated Index Help
PREV PACKAGE NEXT PACKAGE FRAMES NO FRAMES


ru.rapida Class Hierarchy

PREV NEXT FRAMES NO FRAMES

Hierarchy For Package ru.rapida

Class Hierarchy

  • java.lang.Object
    • ru.rapida.RapidaExample
    • ru.rapida.RapidaExample.Request

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
      • ru.rapida.RapidaExample.Request.HTTP_METHOD
Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Package ru.rapida

PREV NEXT FRAMES NO FRAMES

Uses of Package
ru.rapida

Classes in ru.rapida used by ru.rapida
RapidaExample.PAYM_SUBJ_TYPE
Перечисление групп кодов назначения.
RapidaExample.Request.HTTP_METHOD
Перечисление методов HTTP запроса

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


RapidaExample

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD

ru.rapida
Class RapidaExample

java.lang.Object
    extended by  ru.rapida.RapidaExample

public class RapidaExample
extends java.lang.Object

Пример работы с платежной системой "Рапида" (все статические методы используются для примера работы, остальное реализует протокол)
на данный момент корректная работа гарантируется с JRE <= 1.6.0_18

Nested Class Summary
static class | RapidaExample.PAYM_SUBJ_TYPE Перечисление групп кодов назначения.
static class | RapidaExample.Request Класс отправки запроса на сервер
Constructor Summary
RapidaExample(java.lang.String url, java.lang.String termType, java.lang.String termId, javax.net.ssl.SSLSocketFactory sslsf, java.net.Proxy proxy)
Конструктор сласса
Method Summary
byte[] | cancel(java.lang.String paymExtId) Запрос на отмену платежа
byte[] | check(java.lang.String paymExtId, int paymSubjTp, java.util.List<java.lang.String> params, int amount, int feeSum) Запрос проверки правильности параметров платежа
byte[] | getBalance(java.lang.String paymExtId) Запрос на получение остатка средтв участника системы
static javax.net.ssl.SSLSocketFactory | getFactory(java.io.File pkcs12, java.lang.String password) Возвращает объект SSLSocketFactory из контейнера pkcs12
byte[] | getFee() Запрос справочника получателей
byte[] | getPaymSubj(RapidaExample.PAYM_SUBJ_TYPE paym_subj_type, java.lang.String param) Запрос на получение кода ТСП
byte[] | getStatus(java.lang.String paymExtId) Запрос статуса платежа
static void | main(java.lang.String[] args) Пример использования класса (все статические методы используются для примера работы)
static java.lang.String | makePaymExtId() Создает paymExtId (рекомендуется реализовать более надежный алгоритм)
byte[] | payment(java.lang.String paymExtId, int paymSubjTp, java.util.List<java.lang.String> params, int amount, int feeSum) Запрос проведения платежа
static void | respAlalyzer(byte[] resp) Анализирует ответ сервера.
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RapidaExample

public RapidaExample(java.lang.String url,
                     java.lang.String termType,
                     java.lang.String termId,
                     javax.net.ssl.SSLSocketFactory sslsf,
                     java.net.Proxy proxy)
Конструктор сласса

Parameters:
url - адрес для запросов
termType - код платежного инструмента
termId - идентификатор ППП
sslsf - параметры шифрования (если не используется, допустимо значение null)
proxy - параметры прокси сервера (если не используется, допустимо значение null)
Method Detail

check

public byte[] check(java.lang.String paymExtId,
                    int paymSubjTp,
                    java.util.List<java.lang.String> params,
                    int amount,
                    int feeSum)
Запрос проверки правильности параметров платежа

Parameters:
paymExtId - идентификатор запроса
paymSubjTp - код получателя
params - параметры платежа
amount - сумма платежа (в копейках)
feeSum - сумма комиссии (в копейках)
Returns:
полученные данные

payment

public byte[] payment(java.lang.String paymExtId,
                      int paymSubjTp,
                      java.util.List<java.lang.String> params,
                      int amount,
                      int feeSum)
Запрос проведения платежа

Parameters:
paymExtId - идентификатор запроса
paymSubjTp - код получателя
params - параметры платежа
amount - сумма платежа (в копейках)
feeSum - сумма комиссии (в копейках)
Returns:
полученные данные

cancel

public byte[] cancel(java.lang.String paymExtId)
Запрос на отмену платежа

Parameters:
paymExtId - идентификатор запроса
Returns:
полученные данные

getPaymSubj

public byte[] getPaymSubj(RapidaExample.PAYM_SUBJ_TYPE paym_subj_type,
                          java.lang.String param)
Запрос на получение кода ТСП

Parameters:
paym_subj_type - код получателя
param - параметр запроса
Returns:
полученные данные

getBalance

public byte[] getBalance(java.lang.String paymExtId)
Запрос на получение остатка средтв участника системы

Parameters:
paymExtId - идентификатор запроса
Returns:
полученные данные

getFee

public byte[] getFee()
Запрос справочника получателей

Returns:
полученные данные

getStatus

public byte[] getStatus(java.lang.String paymExtId)
Запрос статуса платежа

Parameters:
paymExtId - идентификатор запроса
Returns:
полученные данные

makePaymExtId

public static java.lang.String makePaymExtId()
Создает paymExtId (рекомендуется реализовать более надежный алгоритм)

Returns:
идентификатор запроса

getFactory

public static javax.net.ssl.SSLSocketFactory getFactory(java.io.File pkcs12,
                                                        java.lang.String password)
Возвращает объект SSLSocketFactory из контейнера pkcs12

Parameters:
pkcs12 - pkcs12 контейнер
password - пароль к контейнеру
Returns:
SSLSocketFactory

respAlalyzer

public static void respAlalyzer(byte[] resp)
Анализирует ответ сервера. (ответ на запрос справочника полуателей не является стандартным и не может быть проанализирован методом respAlalyzer)

Parameters:
resp - данные полученные от сервера

main

public static void main(java.lang.String[] args)
Пример использования класса (все статические методы используются для примера работы)

Parameters:
args - аргументы запуска
Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD | DETAIL: FIELD | CONSTR | METHOD


RapidaExample.PAYM_SUBJ_TYPE

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD

ru.rapida
Enum RapidaExample.PAYM_SUBJ_TYPE

java.lang.Object
    extended by  java.lang.Enum<RapidaExample.PAYM_SUBJ_TYPE>
        extended by  ru.rapida.RapidaExample.PAYM_SUBJ_TYPE
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<RapidaExample.PAYM_SUBJ_TYPE>
Enclosing class:
RapidaExample
public static enum RapidaExample.PAYM_SUBJ_TYPE
extends java.lang.Enum<RapidaExample.PAYM_SUBJ_TYPE>

Перечисление групп кодов назначения. используется в запросе getPaymSubj

Enum Constant Summary
MOBILE_PHONES
Мобильные телефоны
TICKETS
Билеты
Method Summary
int | getId() Возвращает идентификатор
java.lang.String | toString() Возвращает идентификатор в виде строки
static RapidaExample.PAYM_SUBJ_TYPE | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static RapidaExample.PAYM_SUBJ_TYPE[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

MOBILE_PHONES

public static final RapidaExample.PAYM_SUBJ_TYPE MOBILE_PHONES
Мобильные телефоны

TICKETS

public static final RapidaExample.PAYM_SUBJ_TYPE TICKETS
Билеты

Method Detail

values

public static RapidaExample.PAYM_SUBJ_TYPE[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (RapidaExample.PAYM_SUBJ_TYPE c : RapidaExample.PAYM_SUBJ_TYPE.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RapidaExample.PAYM_SUBJ_TYPE valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null

getId

public int getId()
Возвращает идентификатор

Returns:
идентификатор

toString

public java.lang.String toString()
Возвращает идентификатор в виде строки

Overrides:
toString in class java.lang.Enum<RapidaExample.PAYM_SUBJ_TYPE>
Returns:
идентификатор
Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD DETAIL: ENUM CONSTANTS | FIELD | METHOD


RapidaExample.Request

PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD

ru.rapida
Class RapidaExample.Request

java.lang.Object
    extended by  ru.rapida.RapidaExample.Request
Enclosing class:
RapidaExample
public abstract static class RapidaExample.Request
extends java.lang.Object

Класс отправки запроса на сервер

Nested Class Summary
static class RapidaExample.Request.HTTP_METHOD
Перечисление методов HTTP запроса
Constructor Summary
RapidaExample.Request(java.lang.String url, RapidaExample.Request.HTTP_METHOD method, java.util.Map<java.lang.String,java.lang.String> params, javax.net.ssl.SSLSocketFactory sslsf, java.net.Proxy proxy)
Конструктор объекта
Method Summary
protected abstract byte[] | responseProcessor(byte[] data) Обработчик даннных полученных от сервера (метод send возвращает результат обработки данных от сервера методом responseProcessor)
byte[] | send() Отправляет запрос и возвращает полученные данные
Methods inherited from class java.lang.Object
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

Constructor Detail

RapidaExample.Request

public RapidaExample.Request(java.lang.String url,
                             RapidaExample.Request.HTTP_METHOD method,
                             java.util.Map<java.lang.String,java.lang.String> params,
                             javax.net.ssl.SSLSocketFactory sslsf,
                             java.net.Proxy proxy)
Конструктор объекта

Parameters:
url - URL адрес сервера на который будет отправлен запрос
method - метод передачи параметров
params - параметры запроса
sslsf - SSLSocketFactory, допустимо значение null
proxy - Proxy, допустимо значение null
Method Detail

send

public byte[] send()
Отправляет запрос и возвращает полученные данные

Returns:
полученные данные

responseProcessor

protected abstract byte[] responseProcessor(byte[] data)
Обработчик даннных полученных от сервера (метод send возвращает результат обработки данных от сервера методом responseProcessor)

Parameters:
data - данные полученные от сервера
Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS FRAMES NO FRAMES
SUMMARY: NESTED | FIELD | CONSTR | METHOD DETAIL: FIELD | CONSTR | METHOD


RapidaExample.Request.HTTP_METHOD

PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD

ru.rapida
Enum RapidaExample.Request.HTTP_METHOD

java.lang.Object
    extended by  java.lang.Enum<RapidaExample.Request.HTTP_METHOD>
        extended by  ru.rapida.RapidaExample.Request.HTTP_METHOD
All Implemented Interfaces:
java.io.Serializable, java.lang.Comparable<RapidaExample.Request.HTTP_METHOD>
Enclosing class:
RapidaExample.Request
public static enum RapidaExample.Request.HTTP_METHOD
extends java.lang.Enum<RapidaExample.Request.HTTP_METHOD>

Перечисление методов HTTP запроса

Enum Constant Summary
GET
GET запрос
POST
POST запрос
Method Summary
static RapidaExample.Request.HTTP_METHOD | valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static RapidaExample.Request.HTTP_METHOD[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
Methods inherited from class java.lang.Enum
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
Methods inherited from class java.lang.Object
getClass, notify, notifyAll, wait, wait, wait

Enum Constant Detail

POST

public static final RapidaExample.Request.HTTP_METHOD POST
POST запрос

GET

public static final RapidaExample.Request.HTTP_METHOD GET
GET запрос

Method Detail

values

public static RapidaExample.Request.HTTP_METHOD[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for (RapidaExample.Request.HTTP_METHOD c : RapidaExample.Request.HTTP_METHOD.values())
    System.out.println(c);

Returns:
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RapidaExample.Request.HTTP_METHOD valueOf(java.lang.String name)
Returns the enum constant of this type with the specified name. The string must match exactly an identifier used to declare an enum constant in this type. (Extraneous whitespace characters are not permitted.)

Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
java.lang.IllegalArgumentException - if this enum type has no constant with the specified name
java.lang.NullPointerException - if the argument is null
Package Class Use Tree Deprecated Index Help
PREV CLASS NEXT CLASS | FRAMES NO FRAMES
SUMMARY: NESTED | ENUM CONSTANTS | FIELD | METHOD | DETAIL: ENUM CONSTANTS | FIELD | METHOD


Uses of Class ru.rapida.RapidaExample

PREV NEXT FRAMES NO FRAMES

Uses of Class
ru.rapida.RapidaExample

No usage of ru.rapida.RapidaExample

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class ru.rapida.RapidaExample.PAYM_SUBJ_TYPE

PREV NEXT FRAMES NO FRAMES

Uses of Class
ru.rapida.RapidaExample.PAYM_SUBJ_TYPE

Uses of RapidaExample.PAYM_SUBJ_TYPE in ru.rapida

Methods in ru.rapida that return RapidaExample.PAYM_SUBJ_TYPE
static RapidaExample.PAYM_SUBJ_TYPE | RapidaExample.PAYM_SUBJ_TYPE.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static RapidaExample.PAYM_SUBJ_TYPE[] | RapidaExample.PAYM_SUBJ_TYPE.values() Returns an array containing the constants of this enum type, in the order they are declared.

Methods in ru.rapida with parameters of type RapidaExample.PAYM_SUBJ_TYPE
 byte[] RapidaExample.getPaymSubj(RapidaExample.PAYM_SUBJ_TYPE paym_subj_type, java.lang.String param)
Запрос на получение кода ТСП

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class ru.rapida.RapidaExample.Request

PREV NEXT FRAMES NO FRAMES

Uses of Class
ru.rapida.RapidaExample.Request

No usage of ru.rapida.RapidaExample.Request

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES


Uses of Class ru.rapida.RapidaExample.Request.HTTP_METHOD

PREV NEXT FRAMES NO FRAMES

Uses of Class
ru.rapida.RapidaExample.Request.HTTP_METHOD

Uses of RapidaExample.Request.HTTP_METHOD in ru.rapida

Methods in ru.rapida that return RapidaExample.Request.HTTP_METHOD
static RapidaExample.Request.HTTP_METHOD | RapidaExample.Request.HTTP_METHOD.valueOf(java.lang.String name) Returns the enum constant of this type with the specified name.
static RapidaExample.Request.HTTP_METHOD[] | RapidaExample.Request.HTTP_METHOD.values() Returns an array containing the constants of this enum type, in the order they are declared.

Constructors in ru.rapida with parameters of type RapidaExample.Request.HTTP_METHOD
RapidaExample.Request(java.lang.String url, RapidaExample.Request.HTTP_METHOD method, java.util.Map<java.lang.String,java.lang.String> params, javax.net.ssl.SSLSocketFactory sslsf, java.net.Proxy proxy)
Конструктор объекта

Package Class Use Tree Deprecated Index Help
PREV NEXT FRAMES NO FRAMES