Rapida Delphi SourceSample: Все классы, интерфейсы и объекты

Все классы, интерфейсы и объекты

Имя | Модуль | Описание
TDMod | DataUnit | Общий модуль
TFee | DataUnit | Обьект под комиссии/ограничения агента, системы
TFeeRec | DataUnit | Фиксированная ставка, процентная, минимальная комиссия, максимальная, минимальная сумма, максимальная


Rapida Delphi SourceSample: Все константы

Все константы

Модули не содержат констант.


Rapida Delphi SourceSample: Все процедуры и функции

Все процедуры и функции

Модули не содержат функции и процедуры.


Rapida Delphi SourceSample: Все идентификаторы

Все идентификаторы

Имя | Модуль | Описание
DMod | DataUnit |
TDMod | DataUnit | Общий модуль
TFee | DataUnit | Обьект под комиссии/ограничения агента, системы
TFeeRec | DataUnit | Фиксированная ставка, процентная, минимальная комиссия, максимальная, минимальная сумма, максимальная


Rapida Delphi SourceSample: Все типы

Все типы

Модули не содержат типов.


Rapida Delphi SourceSample: Все модули

Все модули

Имя | Описание
DataUnit | Главный модуль Пример работы с протоколом Rapida (продукт ПП Платежи) Рапида Москва 2011


Rapida Delphi SourceSample: Все переменные

Все переменные

Имя Модуль Описание


Rapida Delphi SourceSample: Иерархия классов

Иерархия классов

  • TFee
  • TDMod


Rapida Delphi SourceSample: DataUnit

Модуль DataUnit

Описание Используемые модули Классы, интерфейсы и объекты Процедуры и функции Типы Константы Переменные

Описание

Главный модуль

Пример работы с протоколом Rapida (продукт ПП Платежи)
Рапида Москва 2011

Обзор

Классы, интерфейсы и объекты

Имя | Описание
Класс TDMod |
record TFeeRec |
Класс TFee |

Переменные

DMod: TDMod;

Описание

Переменные

DMod: TDMod;


Rapida Delphi SourceSample: DataUnit: Класс TDMod

Класс TDMod

Описание Иерархия Поля Методы Свойства

Модуль

DataUnit

Объявления

type TDMod = class(TDataModule)

Описание

Общий модуль

Иерархия

  • TDataModule
  • TDMod

Обзор

Поля

Public | HTTPS: TIdHTTP;
Public | SSLIOHandler: TIdSSLIOHandlerSocketOpenSSL;
Public | XMLDoc: TXMLDocument;

Методы

Public | procedure SSLIOHandlerGetPassword(var Password: String);
Public | procedure DataModuleCreate(Sender: TObject);
Public | procedure DataModuleDestroy(Sender: TObject);
Public | procedure SetProxy(Use: boolean; const Server: AnsiString = ''; Port: integer = 0; const UserName: AnsiString = ''; const Password: AnsiString = '');
Public | function HTTPSGet(const Path, Params: AnsiString): AnsiString;
Public | function HTTPSPost(const Path, Params, FormParams: AnsiString): AnsiString;
Public | procedure TestConnect;
Public | function GetBalance: AnsiString;
Public | procedure GetFee(trvTsp: TTreeView);
Public | function PaymExtIdGen: AnsiString;
Public | procedure Check(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer);
Public | procedure Payment(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer);
Public | function GetInfo(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer): AnsiString;

Свойства

Public | property PPoint: AnsiString read FPPoint write FPPoint;
Public | property Host: AnsiString read FHost write FHost;
Public | property Certificate: AnsiString read FCertificate write SetCertificate;
Public | property Password: AnsiString read FPassword write FPassword;
Public | property FeeList: TStringList read FFeeList write FFeeList;

Описание

Поля

Public HTTPS: TIdHTTP;
Public SSLIOHandler: TIdSSLIOHandlerSocketOpenSSL;
Public XMLDoc: TXMLDocument;

Методы

Public procedure SSLIOHandlerGetPassword(var Password: String);
Public procedure DataModuleCreate(Sender: TObject);
Public procedure DataModuleDestroy(Sender: TObject);
Public procedure SetProxy(Use: boolean; const Server: AnsiString = ''; Port: integer = 0; const UserName: AnsiString = ''; const Password: AnsiString = '');

Задает настройки прокси

Public function HTTPSGet(const Path, Params: AnsiString): AnsiString;

GET запрос к серверу

Public function HTTPSPost(const Path, Params, FormParams: AnsiString): AnsiString;

POST запрос к серверу. в настоящее время не реализован в протоколе. Оставлен для возможного развития протокола.

Public procedure TestConnect;

Проверяет конект к серверу Рапида

Public function GetBalance: AnsiString;

Получает баланс агента (параметры не нужны, идентификация агента идет по изформации из сертификата)

Public procedure GetFee(trvTsp: TTreeView);

Получает список ТСП и комиссий настроенных агенту

Public function PaymExtIdGen: AnsiString;

Генерирует уникальный ID платежа (используется имя точки, которые обязательно должны быть уникальными)

Public procedure Check(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer);

Проверка на возможность платежа

Public procedure Payment(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer);

Попытка платежа (если до этого не было проверки то платеж "одношаговый")

Public function GetInfo(const ExtId, TSPCode, Params: AnsiString; Amount, FeeS, FeeA: integer): AnsiString;

Информация о... здесь получение денег на счету клиента (МГТС/Utc + ... возможны добавления)

Свойства

Public property PPoint: AnsiString read FPPoint write FPPoint;

Имя точки от которой идут платежи, по идее должно быть уникально для каждой точки, поэтому используем ее для генерации кода платежа

Public property Host: AnsiString read FHost write FHost;

http адрес, на данный момент для боевого режима = https://gate.rapida.ru/gate
для тестового = https://gate.rapida.ru/test

Public property Certificate: AnsiString read FCertificate write SetCertificate;

Имя используемого сертификата X.509 имя файлов сертификата получается из него
добавлением расширений ".cer" для собственно серификата и ".key" для ключа

Public property Password: AnsiString read FPassword write FPassword;

Пароль сертификата

Public property FeeList: TStringList read FFeeList write FFeeList;

Список для хранения комиссий, поиска их по коду ТСП


Rapida Delphi SourceSample: DataUnit: Класс TFee

Класс TFee

Описание Иерархия Поля Методы Свойства

Модуль

DataUnit

Объявления

type TFee = class(TObject)

Описание

Обьект под комиссии/ограничения агента, системы

Иерархия

  • TObject
  • TFee

Обзор

Поля

Public | agt: TFeeRec;
Public | sys: TFeeRec;

Описание

Поля

Public agt: TFeeRec;
Public sys: TFeeRec;


Rapida Delphi SourceSample: DataUnit: record TFeeRec

record TFeeRec

Описание Иерархия Поля Методы Свойства

Модуль

DataUnit

Объявления

type TFeeRec = record

Описание

Фиксированная ставка, процентная, минимальная комиссия, максимальная, минимальная сумма, максимальная

Обзор

Поля

fix: Extended;
perc: Extended;
min: Extended;
max: Extended;
minsum: Extended;
maxsum: Extended;

Описание

Поля

fix: Extended;
perc: Extended;
min: Extended;
max: Extended;
minsum: Extended;
maxsum: Extended;
Сгенерировал PasDoc 0.12.1 дата/время 2011-07-19 17:07:48


Rapida Delphi SourceSample: Обозначения

Обозначения

Маркер | Зона видимости
Strict Private | Strict Private
Private | Private
Strict Protected | Strict Protected
Protected | Protected
Public | Public
Published | Published
Automated | Automated
Implicit | Implicit


Navigation

Rapida Delphi SourceSample

Модули
Иерархия классов
Классы, интерфейсы и объекты
Типы
Переменные
Константы
Процедуры и функции
Идентификаторы